Ether 1 – Internet Gateway

Berikan IP pada antarmuka gateway antarmukanya sekalian Ether 2 dan Wlan

/ip address
add address=192.168.1.253/24 interface=ether1 network=192.168.1.0
add address=192.168.100.1/24 interface=ether2 network=192.168.100.0
add address=192.168.200.1/24 interface=wlan1 network=192.168.200.0

Selanjutnya kita berikan rule routing yang dimana jika IP Address yang dimaksud tidak diketahui maka akan diteruskan ke jaringan publik (ether1)

/ip route
add distance=1 gateway= XXXXXX sesuaikan ISP contoh 192.168.1.1

Agar jaringan di antarmuka lain bisa ke internet kita juga harus menambahkan fitur NAT yang mengarah ke ether1

/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1

Karena jika berselancar kita mengakses menggunakan nama Domain dan bukan IP maka kita harus atur juga DNS dengan perintah di bawah ini. Sedikit catatan saya menggunakan DNS Google, Tapi bisa juga nnti di beri DNS sesuai tempat anda

 

/ip dns
set allow-remote-requests=yes servers=8.8.8.8

 

Seharusnya saat ini teman-teman sudah berhasil terhubung ke internet, silahkan untuk mengecek di dari PC yang terhubung ke ether 2 bisa berselancar atau tidak. Namun sebelumnya isi dulu IP PC nya dengan yang satu network dengan ether2.

 

Network Time Protocol

Secara bawaan waktu pada Router MikroTik adalah tahun 1970. Untuk menyetarakan dengan kondisi saat ini bisa saja namun sebenarnya ada fungsi Network Time Protol atau NTP. NTP adalah layanan yang berfungsi untuk menyamakan waktu antar perangkat. NTP dilakukan setelah router terkoneksi ke internet agar bisa mengecek ke server waktu internasional. Untuk mengkonfigurasinya teman-teman bisa ke System > SNTP Client, lalu buat seperti di bawah ini dan terakhir klik OK. 

Saat ini router kita telah terhubung dengan sistem waktu internasional, selanjutnya tinggal kita sesuaikan dengan daerah kita. Caranya bisa ke System > Clock lalu klik Time Zone Autodetect dan pada kolom Time Zone Name cari Asia/Jakarta dan klik OK. Saat ini router kita telah memiliki waktu yang real.

 

Ether 2 – Modul DHCP

Sesuai dengan soal bahwa di Ether2 disuruh membuat DHCP Server. Karena DHCP Server cukup sulit ketika menggunakan CLI maka saya akan menggunakan Winbox saja. Silahkan teman-teman menuju IP > DHCP Server pada tab DHCP pilih DHCP Setup. Di tampilan ini silahkan pilih ether2 karena kita akan membuat DHCP Server pada ether2

Pada pemilihan network dibiarkan saja karena secara otomatis akan menyesuaikan dengan prefix yang kita isi di ether2

Untuk gateway dibiarkan juga karena secara otomatis akan menyesuiakan dengan IP Address yang terpasang di ether2

Untuk alamat yang diberikan secara bawaan router akan menentukan mengikuti subnetting, tetapi kita akan ubah jadi 100 karena di soal perintahnya seperti itu.

DHCP Relay biarkan kosong karena kita tidak menggunakan fitur ini

Sekarang silahkan teman-teman periksa pada komputer yang disambungkan ke ether2, seharusnya saat ini telah mendapatkan IP secara DHCP.

Ether 2 – Static DNS

Fitur static DNS ini digunakan ketika kita ingin mendifinisikan domain pada router kita sendiri. Sehingga ketika pengguna mengakses suatu domain maka akan diarahkan ke tujuan tertentu. Untuk menggunakan fitur ini silahkan pergi ke IP > DNS > Static > + (add) lalu tambahkan domain yang akan didefinisikan pada Name serta tujuannya yaitu bsnp-indonesia.org pada Address. Sedikit catatan ketika kita klik tombol OK atau Apply, si router akan mentranslasikan domain yg kita masukkan ke alamat IP domain tersebut.

Sebenarnya kolom Address hanyalah bisa membaca IP, namun pada fitur mikrotik yang baru dimana bisa melakukan resolve pada domain maka ketika kita memasukkan domain bsnp-indonesia.org akan otomatis berubah menjadi IP Address dari bsnp-indonesia.org.

Setelah tahap ini selesai silahkan coba membuka www.mikrotik.com pada peramban teman-teman, kemungkinan tampilan yang akan muncul adalah seperti di bawah ini. Sebenarnya situs mikrotik.com telah terarahkan ke bsnp-indonesia.org atau lebih tepatnya ke IP server bsnp-indonesia.org. Maka dari itu untuk redirect menggunakan DNS statis ini sebenarnya agak janggal ditaruh dalam kondisi seperti ini.

Ether 2 – Blokir PING

Firewall pertama yang akan dibuat adalah pembatasan IP 192.168.100.2 – 192.168.100.50 tidak bisa melakukan ping ke Router. Karena saat ini kita memiliki 3 IP Address pada router maka semua IP Address ini harus dimasukkan ke dalam rule.

/ip firewall filter
add action=drop chain=input dst-address=192.168.1.253 protocol=icmp src-address=192.168.100.2-192.168.100.50
add action=drop chain=input dst-address=192.168.100.1 protocol=icmp src-address=192.168.100.2-192.168.100.50
add action=drop chain=input dst-address=192.168.200.1 protocol=icmp src-address=192.168.100.2-192.168.100.50

Arti dari perintah di atas adalah jika ada paket ping (icmp) yang masuk ke router melalui IP tersebut maka akan di drop. Sebenarnya ada cara lain dengan menggunakan address list namun saya pilih ini karena secara lebih simpel baik melalui CLI dan GUI. Sekarang silahkan uji dari komputer kalian apakah ping ke router masih bisa atau tidak.

Ether 2 – Logging

Sebenarnya saya cukup bingung dengan perintah yang satu ini. Di soal tertulis “Buat rule agar setiap akses ke router tercatat di logging”. Ini maksudnya apakah log ketika pengguna masuk ke router atau log bagi semua aktivitas yang masuk ke router? 

Jika maksdunya adalah log ketika pengguna masuk ke router maka ini sudah ada secara bawaan, silahkan cek log router teman-teman pastinya ada laporan ketika pengguna masuk dengan laporan berhasil atau tidak. Sedangkan jika log semua aktivitas maka pada menu log akan sangat banyak baris yang tercipta. Dimana nantinya khawatir baris yang berfungsi sebagai bahan analisa malah “tenggelam”.

Tetapi di luar itu saya coba menangkap mungkin maksud ke 2 yang benar, yaitu semua aktivitas yang masuk ke router yang dicatat. Jadi kita akan membuat rule nya, tetapi satu hal yang harus teman-teman ketahui inti dari rule ini adalah aktifitas yang sesuai akan masuk ke dalam LOG.

/ip firewall filter
add chain=input log=yes log-prefix=login

Perhatikan di situ ada log=yes dan itulah yang menjadi fokus teman-teman, ketika nanti soalnya diganti atau diperbaharui semoga kalian bisa. Oh yaa arti log-prefix di perintah tersebut adalah untuk memberi tanda di LOG bahwa yang menggunakan kata login sebagai prefix merupakan log yang dibuat oleh aturan firewall yang kita masukkan.

 

Ether 2 – Rule HTTP dan HTTPS

Ini juga membuat saya bingung, karena secara bawaan ketika saya mengaktifkan fitur NAT maka secara otomatis pengguna dari CLIENT Network bisa mengakses ke internet. Namun saya ada pandangan lain, dimana mungkin maksudnya adalah CLIENT Network ke Internet hanya diizinkan mengakses HTTP & HTTPS saja dan akses lain seperti PING akan diblokir.

/ip firewall filter
add action=drop chain=forward dst-port=!80,443 in-interface=ether2 out-interface=ether1 protocol=tcp

Sekarang silahkan kalian coba akses www.google.com (80 & 443) dari peramban, seharusnya bisa berjalan dengan baik. Lalu setelah itu coba akses ke ftp://ftp.itb.ac.id/ (port 21) dan seharusnya yang menggunakan port 21 tidak bisa diakses.

WLAN 1 – Hotspot

Sebenarnya pada soal di bagian wireless tidak ada kata-kata hotspot, namun jika dilihat dari topologi ada tulisan hotspot yang di wlan1 dan non hotspot di ether2. Jadi saya beranggapan bahwa di soal ini ada maksud bahwa wlan1 digunakan sebagai hotspot login namun tidak didefinisikan lebih lanjut lagi.

Sebelum membuat hotspot, kita akan ubah dulu mode wlan1 menjadi pemancar atau AP-Bridge. Teman-teman bisa menuju ke menu Interfaces > tab interface > wlan1 lalu pada tab wireless ganti mode menjadi AP-Bridge dan SSID menjadi Ariyolo@Proxy.

Jika wlan1 sudah menjadi pemancar maka selanjutnya tinggal tahapan hotspot. Silahkan menuju ke IP > Hotspot > tab Server > Hotspot Setup. Lalu pilih antarmuka yang akan dijadikan hotspot, dalam hal ini adalah wlan1.

Di tampilan selanjutnya Untuk alamat IP akan menyesuaikan dengan IP yang telah kita isi di awal-awal pembahasan. Selanjutnya yang dilakukan adalah unchecklist pada Masquerade Network karena kita telah membuat NAT Masquerade di awal pembahasan pada Ether1 – Internet Gateway. 

Untuk address pool ubah dari 192.168.200.2 – 192.168.200.254 menjadi hanya sampai 100 saja agar sesuai dengan soal. 

Selanjutnya karena kita tidak memiliki sertifikat SSL maka pada tampilan ini pilih Next saja. 

IP Address of SMTP Server biarkan saja dan langsung pilih Next karena kita tidak menggunakannya. 

Untuk DNS secara otomatis akan menyesuikan dengan yang ada di pengaturan DNS dari router. Pada bagian ini juga sama, yaitu diamkan saja. 

Pada tahapan selanjutnya teman-teman diminta untuk memasukkan domain yang akan digunakan untuk mengakses portal hotspot. Contoh pada kali ini saya isi dengan ariyolo.local 

Tahapan terakhir adalah menentukan nama pengguna dan kata sandi yang bisa digunakan untuk masuk ke dalam hotspot. Karena tidak ada ketentuan seperti soal-soal UPK paket atau tahun yang lain jadi biar cepat saya isi seperti di bawah ini saja. 

Jika telah selesai silahkan untuk masuk ke hotspot portal dan pastikan teman-teman bisa mengakses Internet.

Wlan 1 – Proxy

Untuk mengaktifkan Proxy cukup mudah yaitu dengan pergi ke IP > Proxy lalu pada tab General lakukan checklist pada pilihan Enable maka Proxy akan berjalan pada port 8080. Pada kolom cache administrator jangan lupa mengisi ariyolo@sekolah.sch.id, karena itu ada di soal.

Sampai saat ini proxy telah aktif, namun agar pengguna bisa terkena efek dari Proxy ini pengguna harus melakukan pengaturan pada perampan mereka. Cara lain agar pengguna bisa otomatis terkeda dampak dari Proxy adalah dengan menggunakan bantuan rule pada firewall untuk membuat Transparent Proxy. Caranya adalah dengan menggunakan perintah seperti di bawah ini (winbox menyesuaikan). Karena hanya wlan1 saja yang terkena dampaknya maka pada in-interface diisi wlan1.

/ip firewall nat
add action=redirect chain=dstnat dst-port=80 in-interface=wlan1 protocol=tcp to-ports=8080

Wlan 1 – Pemblokiran Situs

Pemblokiran situs sebenarnya bisa menggunakan Firewall dan DNS Static, namun kalau dilihat-lihat tampaknya pembuat soal menginginkan kita menggunakan Proxy. Maka dari itu teman-teman silahkan pergi ke IP > Proxy > tab general > tombol access lalu tambahkan rule baru seperti di bawah ini.  

Bloking File Mp3.DLL

pertama-tama coba kalian download music yang berekstensi .mp3
jika sudah sekarang silakan masuk ke mikrotik anda melalui winbox
setelah masuk sekarang masuk ke tab IP--->firewall---->filter rules----> klik tanda tambah ( + )
pada tab general silakan isi seperti berikut
chain = forward
src address = network dari klien kalian
protocol = tcp
dst. port = 80
 
sekarang pindah ke tab advanced, silakan isi content dengan ekstensi apa yang ingin kalian blok
misal : mp3, mp4, dll
pindah lagi ke tab action, acction = drop kemudian apply trus ok
sekarang cek dengan mencoba mendownload kembali musik dengan format yang di blok tadi